Google планирует скрывать приложения, собранные с устаревшей версией TargetSDK

7.04.2022 | Новости

Компания Google предупредила разработчиков, что будут усилены требования к уровню Target API (Android API), для которого собираются приложения. На практике это означает, что с 1 ноября 2022 года приложения в магазине Google Play не будут доступны для поиска и установки, если при их создании использовался устаревший TargetSDK (срок давности которого превышает два года). По мере выхода новых релизов Android, окно версий, в рамках которого можно указывать целевой уровень, будет меняться соответствующим образом.

В настоящий момент требуется, чтобы все новые приложения и обновления текущих приложений были собраны с Target SDK не ниже последней актуальной версии ОС Android (или любой версии, которая вышла в течении года с момента выхода последней версии).

Эти изменения проще всего представить в виде небольшой временной шкалы:

Визуализация новых правил

Конечно, большинство приложений уже соответствуют этому правилу — они собраны с правильной версией TargetSDK. Так что это нововведение коснется только тех разработок, у которых достаточно давно не было обновлений.

С точки зрения безопасности пользователей это, безусловно, правильный шаг, который позволит убрать из магазина всё, что, по мнению Google, может стать причиной компрометации данных пользователя. Это логичный этап в реализации стратегии повышения безопасности пользователей, которую реализуют Google и Apple. Они уделяют огромное внимание вопросам приватности, применяя запреты на получение различных идентификаторов устройств и на доступ к различным сенсорам, и многое-многое другое.

Как написано в оригинальном посте, это только одно из нововведений в политике, так что ожидаем и других новостей. Но, как мне кажется, следующим логичным шагом будет аналогичное “окно“ для установки минимальной версии SDK, которое позволит отсечь совсем уж старые устройства, за которые все равно продолжают держаться компании, чтобы не потерять несколько процентов своих пользователей.

Ссылка на оригинальный пост: https://android-developers.googleblog.com/2022/04/expanding-plays-target-level-api-requirements-to-strengthen-user-security.html

Спасибо за внимание!

Подпишитесь на telegram канал